UNIFI-VIDEO start …fail!

Nach einem normalen Tag voller Updates meldet sich der NVR plötzlich ab und verweigert den Start. Aus den Logs lässt sich nur erahnen womit das ganze zusammen hängt.

Sep 15 14:59:19 video systemd[1]: Starting LSB: Ubiquiti unifi-video...
Sep 15 14:59:19 video unifi-video[1917]:  * Starting Ubiquiti UniFi Video unifi-video
Sep 15 14:59:20 video unifi-video[1996]: (unifi-video) Hardware type:Unknown
Sep 15 14:59:20 video unifi-video[1996]: (unifi-video) checking for system.properties and truststore files...
Sep 15 14:59:21 unifi unifi-video[1917]:    ...fail!
Sep 15 14:59:21 unifi systemd[1]: Started LSB: Ubiquiti unifi-video.

Nach kurzen suchen in UI Forum stieß ich auf ähnliche Beiträge und eine ganz simple Erklärung. Mit dem letzten Java Update hat es UNIFI-VIDEO entschärft.

Problem is the Java version. Latest that v3.10.13 video will run on is 8u275.
Also latest Camera FW that Video supports is "v4.23.8" - don't go above that!
  1. Download der Java Version „jre-8u271-linux-x64.tar.gz“
  2. Login als root (sudo su)
  3. mkdir /usr/local/java (wenn nicht schon vorhanden)
  4. cp jre-8u271-linux-x64.tar.gz /usr/local/java
  5. cd /usr/local/java
  6. tar zxvf jre-8u271-linux-x64.tar.gz
  7. rm jre-8u271-linux-x64.tar.gz
  8. update-alternatives –install „/usr/bin/java“ „java“ „/usr/local/java/jre1.8.0_271/bin/java“ 1
  9. update-alternatives –config java (auf meinem System war Auswahl „2“)
    *2 /usr/local/java/jre1.8.0_271/bin/java 1 manueller Modus
  10. echo „JAVA_HOME=/usr/local/java/jre1.8.0_271“ | tee -a /etc/default/unifi
  11. reboot (nun funktioniert auch der UNIFI-VIDEO wieder)

Mikrotik – Channel Liste

2ghz

/caps-man channel add band=2ghz-b/g/n name=CH1 frequency=2412 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH2 frequency=2417 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH3 frequency=2422 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH4 frequency=2427 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH5 frequency=2432 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH6 frequency=2437 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH7 frequency=2442 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH8 frequency=2447 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH9 frequency=2452 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH10 frequency=2457 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH11 frequency=2462 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH12 frequency=2467 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH13 frequency=2472 extension-channel=Ce control-channel-width=20mhz


5Ghz:
/caps-man channel add band=5ghz-a/n/ac name=CH36 frequency=5180 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH40 frequency=5200 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH44 frequency=5220 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH48 frequency=5240 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH52 frequency=5260 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH56 frequency=5280 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH60 frequency=5300 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH64 frequency=5320 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH100 frequency=5500 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH104 frequency=5520 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH108 frequency=5540 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH112 frequency=5560 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH116 frequency=5580 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH120 frequency=5600 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH124 frequency=5620 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH128 frequency=5640 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH132 frequency=5660 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH136 frequency=5680 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH140 frequency=5700 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH149 frequency=5745 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH153 frequency=5765 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH157 frequency=5785 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH161 frequency=5805 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH165 frequency=5825 extension-channel=Ceee control-channel-width=20mhz

iobroker installieren

In meinem Fall gehe ich davon aus, das ein neu aufgesetztes System vor mir liegt.

Der ioBroker benötigt einaktuelles nodeJS, dies in der Code-Zeile vorher anpassen!

apt-get update
apt-get dist-upgrade

curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bash -

apt install -y nodejs

	
curl -sL https://iobroker.net/install.sh | bash -

Und fertig.