Error in OMV4.x bei update

Wenn apt-get update/upgrade einen error auswirft der die weakref.py betrifft

Dann folgendes ausführen!

wget -O /usr/lib/python3.5/weakref.py https://raw.githubusercontent.com/python/cpython/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6/Lib/weakref.py

Oder wenn man es lieber von Hand macht:

nano /usr/lib/python3.5/weakref.py 

Edit Zeile 109:
def remove(wr, selfref=ref(self), _atomic_removal=_remove_dead_weakref):

Edit Zeile 117:
_atomic_removal(d, wr.key)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.