Ai-on-the-edge-device / ESP32-Cam Flashen

Es geht um diesen tolle Projekt hier: HIER

Auf YouTube gibt es ein schönes deutschsprachiges Tutorial Video dazu: HIER

Da ich sowohl unter Windows wie auch MacOS meine Probleme beim Flashen hatte, hier meine Vorgehensweise auf dem Mac:

  • Terminal öffnen
  • Homebrew installieren
$ /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"
  • Python installieren
$ brew install python
  • pyserial installieren
$ python3 -m pip install pyserial
  • Dateien runterladen:
    • https://github.com/jomjol/AI-on-the-edge-device
    • https://github.com/espressif/esptool
  • Dateien entpacken
  • in das Verzeichnis wechseln, wo die oben genannten Dateien parallel liegen

  • kontrollieren ob der ESP32+FTDI erkannt wird
$ ls -la /dev/cu.*
  • ESP32-Cam flashen (Port und Verzeichnisnamen anpassen!)
python3 ./esptool-3.2/esptool.py \
	--port /dev/cu.usbserial-2240 write_flash \
	0x01000 ./AI-on-the-edge-device-9.2.0/firmware/bootloader.bin \
	0x08000 ./AI-on-the-edge-device-9.2.0/firmware/partitions.bin \
	0x10000 ./AI-on-the-edge-device-9.2.0/firmware/firmware.bin 

weitere Quellen:

https://docs.python-guide.org/starting/install3/osx/

https://pyserial.readthedocs.io/en/latest/pyserial.html

Blue Iris -profile change http-request

Ich wollte, das wenn ich das Haus verlasse, die Kameras erst „scharf“ gestellt werden bzw. mir erst dann push-Mittteilungen gesendet werden.

Dazu ist einfach nur ein Web.request nötig:

command_on: ‘curl -k “http://ip:port/admin?profile=1& user=username&pw=password”’
command_off: ‘curl -k “http://ip:port/admin?profile=2& user=username&pw=password”’

Im ioBroker noch ein kleines Blockly Skript verfasst:

Das Profil wird nach wenigen Sekunden gewechselt, aber nur in den „TEMP“ Modus. Laut Einstellungen wechselt das Profil wieder zum „Profil 1“ und stellt dies auf „Play“.

Laut Forum gibt es noch kein Patch um den „Lock“ Status auf „Play“ zu setzen –> HIER

Quelle 2

BlueIris – Motion Detection optimieren

.. You set zone crossing with 2 zones.  
For example…
1. Set zone A with the side of the house and top stoop.
2. Set zone B to the brick area, and out a bit in the yard and side of the driveway.
3. Connect zones A and B together or they cannot cross – so, add an addition zone (I always use G) that covers zone A, the gap, and Zone B. Basically just cover the dimmer yellow areas.
4. Set your ‚Zone Crosses‘ to A-B.
5. Set the ‚Min. Duration‘ to a lower number, like .2 or .4. You can estimate this by how long it takes a person to move about 1/4 to 1/3 the way thru from the edge of either side of the zones.
6. Set the ‚Object travel‘ to a number, like 50 – 100.

Quelle: Forum

Proxmox – Win10 VM

Vorhanden:

HP ProLiant DL 380 Gen8 – Proxmox PVE

Problem:

  • Bei der Windows 10 VM wurde die Intel Netzwerkkarte nicht erkannt

Weg:

  • Mehrer ISOs von Windows 10 probiert, bei der VM mal die Intel Variante e1000 oder VirtIO gewählt bei Netzwerk
  • Bei einer älteren ISO hatte es geklappt, doch nach dem Windows Update, war das Netzwerk wieder weg

Lösung:

Proxmox upgrade v6 -> v7

  1. alle VM´s beenden

2. Source.list verändern

nano /etc/apt/sources.list
# PVE pve-no-sub
deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription

sollte dann so aussehen:

3. Danach alles auf Debian anpassen

sed -i 's/buster\/updates/bullseye-security/g;s/buster/bullseye/g' /etc/apt/sources.list

4. update + list-upgrade

apt update
apt dist-upgrade

Node.js Upgrade/Downgrade

Nicht immer ist die aktuellste Version auch die empfohlene Version für ioBroker.

Nun ja, sollte es dennoch passiert sein, hier ein möglicher Weg zum downgrade:

Welche Version ist installiert?

node -v

Die angezeigte Version ist jene, welche grad aktiv auf der Maschine läuft.

Um einfach zwischen den Versionen wechseln zu können, wird das Programm „n“ installiert.

sudo npm install -g n

Upgrading zur letzten „Stable“ Version

sudo n stable

Wechsel zu einer bestimmten Version

Um zu einer einer bestimmten Version von Node zu wechseln:

sudo n 10.16.0

Eine Liste der releases, findest du hier.

Mikrotik – Channel Liste

2ghz

/caps-man channel add band=2ghz-b/g/n name=CH1 frequency=2412 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH2 frequency=2417 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH3 frequency=2422 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH4 frequency=2427 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH5 frequency=2432 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH6 frequency=2437 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH7 frequency=2442 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH8 frequency=2447 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH9 frequency=2452 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH10 frequency=2457 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH11 frequency=2462 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH12 frequency=2467 extension-channel=Ce control-channel-width=20mhz
/caps-man channel add band=2ghz-b/g/n name=CH13 frequency=2472 extension-channel=Ce control-channel-width=20mhz


5Ghz:
/caps-man channel add band=5ghz-a/n/ac name=CH36 frequency=5180 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH40 frequency=5200 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH44 frequency=5220 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH48 frequency=5240 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH52 frequency=5260 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH56 frequency=5280 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH60 frequency=5300 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH64 frequency=5320 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH100 frequency=5500 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH104 frequency=5520 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH108 frequency=5540 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH112 frequency=5560 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH116 frequency=5580 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH120 frequency=5600 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH124 frequency=5620 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH128 frequency=5640 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH132 frequency=5660 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH136 frequency=5680 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH140 frequency=5700 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH149 frequency=5745 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH153 frequency=5765 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH157 frequency=5785 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH161 frequency=5805 extension-channel=Ceee control-channel-width=20mhz
/caps-man channel add band=5ghz-a/n/ac name=CH165 frequency=5825 extension-channel=Ceee control-channel-width=20mhz